2

I'm using a Magento 2.4.0 installation, and I've added special price and cost to my product grid in Products / Inventory / Catalog.

Now I have the special price and cost into the grid, but both show 0.00, even if the field is filled and showing when editing the single product and checking the advanced pricing.

Any suggestion to get those shown?

5
  • Have you doing the re-indexing one's set above things? Dec 22, 2021 at 4:39
  • Yes.. run php bin/magento indexer:reindex command once and check result Dec 22, 2021 at 4:57
  • @DhirenVasoya I have already tried to do that, and still nothing, shows same "0.00", and the values and dates are filled.
    – alexcr
    Dec 22, 2021 at 16:23
  • Try saving the product and check it that work Dec 27, 2021 at 19:25
  • @NileshDubey what do you mean, edit the product then save it? Already tried, and nothing, the data shows in advanced pricing fields, but not in the product grid. Curious thing is that if I leave the fields empty, product feed fields are empty aswell, if I enter a value, then product grid field are 0.
    – alexcr
    Dec 27, 2021 at 20:17

2 Answers 2

1

You added a Price You added a Cost You added a Special price

If you havent added a price it would probably go to 0? Could you check?

3
  • Yes, there is also the price, the normal price, and that appears correctly, but the other 2 not at all, those are added from advanced pricing.
    – alexcr
    Dec 27, 2021 at 20:15
  • Can you check logging in var/log?
    – A D
    Jan 4, 2022 at 15:44
  • Sure, just opened backend and checked catalog, here is what I get into hosting logs: 2022-01-04 17:47:52 UTC [apache][authz_core:error] [pid 45349] [client 35.214.76.254:54914] AH01630: client denied by server configuration: /home/u2-hr4ay48xzgmd/www/mywebsitename.com/public_html/app/etc/config.php
    – alexcr
    Jan 4, 2022 at 17:53
0

Special price should be lesser than the actual cost of the product because a special price is a discounted price of the product according to several criteria, such as quality, quantity, the time frame of purchase, and type of customer. enter image description here

Now make changes accordingly and run the below command in Magento 2.4 root directory

php bin/magento indexer:reindex

php bin/magento c:c

More info: docs.magento

2
  • Tried this aswell, still nothing, shows same 0.00 in products grid for both fields.
    – alexcr
    Jan 2, 2022 at 19:17
  • Did u find the cause of this? Facing same issue in 2.4.3
    – Nadroj467
    Nov 24, 2022 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.