1
[InvalidArgumentException]                                                  
  Package is not installed: magento/project-community-edition-2.4.3.0-patch1  
                                                                              

update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [--with-all-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...

I got this error after update the site from 2.4.2 to 2.4.3-p1. I run this command

composer require  magento/product-community-edition 2.4.3-p1 --no-update
composer update

Please let me know how to fix this error.

Thanks.

3 Answers 3

1

Now I found the solution. I removed the vertex modules in 2.4.2 and it worked well. From 2.4.3 the vertex modules are required module. So I have to add them from 2.4.3 again.

0

first of all, make sure you are using correct require

composer require-commerce magento/product-community-edition 2.4.3-p1 --no-update

for some reason they are using require-commerce

1
  • require-commerce not working for me.
    – Aaron Wang
    Dec 20, 2021 at 21:07
0

Try following require commands

Remove composer.lock file

rm rf composer.lock

Update all dependencies

composer require elasticsearch/elasticsearch ~7.11.0 --no-update
composer require laminas/laminas-serializer ^2.11 --no-update
composer require magento/framework 103.0.3-p1 --no-update
composer require magento/module-elasticsearch 101.0.3 --no-update
composer require ramsey/uuid ~4 --no-update
composer require magento/product-community-edition 2.4.3-p1 --no-update

Run composer update

php -d memory_limit=-1 /usr/local/bin/composer update
2
  • I tried this before, but it's not working It's displaying same error. Package is not installed: magento/project-community-edition-2.4.3.0-patch1
    – Aaron Wang
    Dec 20, 2021 at 21:06
  • I have updated my answer. Please recheck
    – khush gill
    Dec 20, 2021 at 21:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.