I have Magento 2.4.2-p1 EE.

When i filter orders by dates, example: Purchase Date: 12/12/2021 - 12/12/2021 enter image description here

I have result with 777 found orders.

enter image description here

But on last page i can see orders with wrong dates for active filters. How fix this?

enter image description here

  • What's your timezone? I guess it's +4hours to UTC or someting? Do you have different timezones configured for Admin and Frontend? Dec 13, 2021 at 8:48
  • @simonthesorcerer i too think problem with timezone. Maybe I'm just in a different time zone and therefore everything is displayed a little incorrectly for me? Dec 13, 2021 at 9:29

1 Answer 1


Method to Configure Magento 2 Stores and Time Zones:

Login to Admin Panel

Navigate to Stores > Configuration

From the left side navigation menu, select the General tab under the General menu.

Here you’ll find the locale and store information dropdown menu

.1_General Expand the locale drop-down option and configure the below settings

2 Stores and Time Zones Time Zone – Set the time zone of the store

Save the configuration Navigate to System > Cache Management > Flush Magento Cache and clear the cache

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.