After installation of Magento 2.4.2 both frontend and backend The Admin panel only displays as the attached file. Why is that and how to fix it?

enter image description here

  • Which version did you move from? 2.4.2 makes it mandatory to move the main part of the site into /pub folder. So you will need to make changes to your .conf file to adapt the new folders. Dec 5, 2021 at 2:39
  • you want to inspect and see what path for css is being loaded based on that we can narrow down the problem and provide better explanation.
    – rex
    Dec 5, 2021 at 23:59

4 Answers 4


Check configuration of your web server and how it matches change in location of index.php. This file has been moved to /pub folder so your nginx or apache configuration needs to be changed to match the new location.

Check release notes for instructions on how to handle this: https://devdocs.magento.com/guides/v2.4/release-notes/open-source-2-4-2.html enter image description here

  • Hey! I did an uninstallation and reinstall a new Magento and everything works as expected. I want to close the case but I don't know how, please show med how to close this case, thank you.
    – CVT
    Dec 28, 2021 at 22:38

I assuming You installed just apache and mysql.And same issue i have faced. You can check this link and will solve it. https://magento.stackexchange.com/a/120109/85907

You need AllowOverride All in this file /etc/apache2/apache2.conf:-

and replace this code :

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride none
Require all granted


<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted



Try running the following commands:

php bin/magento s:up

php bin/magento s:d:c

php bin/magento indexer:reindex

php bin/magento setup:static-content:deploy -f

php bin/magento c:c

php bin/magento c:f


I am facing same issue, I resolved this issue changing base url setting.

Change Base Url with secure url address like mentioned below.

bin/magento setup:store-config:set --base-url="https://example.com/"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.