I have removed tax block from all sales page by adding following code.

layout file is Magento_Sales\layout\default.xml

<page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">
        <referenceBlock name="tax" remove="true"/>

Actual Resultsenter image description here

Expected Resultenter image description here

How can I make subtotal shows including tax but tax line is removed by <referenceBlock name="tax" remove="true"/> ?

1 Answer 1


Please Change Tax Setting

Your Product price must be shown as including tax

Go to Store > configuration > sales > tax > tax classes > Price display setting > Display product price in catalog set to Including Tax.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.