3

Running Magento ver. 1.7.0.2

I've got USPS API setup as i'd like, however it does not show up. When I say to show up no matter what, it gives me this front end error:

This shipping method is currently unavailable. If you would like to ship using this >shipping method, please contact us.

The debug code is this:

2014-09-07T06:07:40+00:00 DEBUG (7): Array
(
    [request] => <?xml version="1.0" encoding="UTF-8"?>
<RateV4Request USERID="981ECCEN4803"><Revision>2</Revision><Package ID="0"><Service>ALL</Service><ZipOrigination>62918 </ZipOrigination><ZipDestination>70125</ZipDestination><Pounds>0</Pounds><Ounces>9.6</Ounces><Container>VARIABLE</Container><Size>REGULAR</Size><Machinable>false</Machinable></Package></RateV4Request>

    [result] => Array
        (
            [error] => Illegal scheme supplied, only alphanumeric characters are permitted
            [code] => 0
        )

    [__pid] => 17709
)

I've triple checked the URL's & username / password for the API.

Has anyone seen an issue like this? I did find it one other place on the network, but he had no answers either: http://goo.gl/fW0TWR

2

I think you are running in the USPS update issue, described by WebShopapps here:

http://www.webshopapps.com/blog/2014/01/usps-api-update-january-2014/ http://www.webshopapps.com/usps-shipping-jul.html

USPS plans to retire their RateV3 API on September 28th, 2014. This is the API used in versions of Magento prior to Community Edition 1.5.1. When USPS makes this update, sites running incompatible versions will no longer receive USPS rates.

I know it is the 4th :-)

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.