1

I don't know what i did wrong or what I'm not seeing but got the following problem I can't tackle.

I have set the show incl. and excl. vat in the shop. (Magento 1.9.0.1) If I add a new product it tells me to place a product price. It tells me underneath the bar [EUR] [Incl. VAT]. lets say €50,-

If I save the product Magento shows the product in the shop the prices €50 excl vat and €60.50 incl vat?

How can I configure Magento that the price I put in is actually incl. and not excl?


Thanks MTM but here's the catch for me.. That are precise the options i have selected in my shop.
If i add a new product it tells me to give in a incl.vat price. i did and in store the price magically changes to excl.Vat and the VAT will add up to that price.

i did repeat the same step u told me and made it excl. Just to be sure i refreshed all of the cash. checked at my product it just tell me to put price in [euro]. and not in or ex. I think this is in the dutch translation, but at my product page it changes the label of the input field so something must have happend when i changed the "show prices in or ex" option.

i left the price at 50 and save the product again and once again refreshed the cash.

nothing happend.. the 50 euro shows excl again (as supposed now i guess)

i got the feeling that the option show prices incl vat is just not working and the option show prices excl is always used on the shop side.

3

Go to system >> configurations >> Tax (under Sales) and find Calculation Settings. Check the option is set to Including Tax for each scope.

enter image description here

  • 1
    accept the answer if it helped by clicking the tick so it turns to green :) – MTM Sep 6 '14 at 22:23
1

Ok the Answer for my problem. Magento was showing me excl. VAT prices in the shop regardless setting the show incl or exclusive of both setting in the tax configuration. What caused this is the following. My shop is in The netherlands. My shipping setting was by default (United States): Sales -> Shipping Settings -> Origin (tab) I changed it to The Netherlands. Now my inclusive VAT is indeed Inclusive and Excl. is now Excl.

This solved my problem! Thanks all for taking the time to help solve my problem !!

-1

I want to add one point to MTM's answer: make sure that "Apply Discount on Prices" parameter is set to Including Tax and Apply Customer Tax = After Discount.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.