0

I just upgraded from Magento 2.3.6 to 2.4.3 near the end of the installation I received this error:

enter image description here

Does anyone know why I get this error? What does it mean?

We do have MSI disabled in case that has

This is the error I get when I use PHP 7.4

1 Answer 1

0

It seems that the upgrade requires a function "str_contains()" that only exists in PHP8. Can you try with php8 instead of 7.4 ?

3
  • I actually run PHP 7.3 when if change it to any higher I get a new error message. updated my OP Commented Nov 16, 2021 at 21:07
  • a simple composer require / update is not sufficient to go from 2.3.6 to 2.4.3 There are many modifications that need to be done "manually". Did you set up elasticsearch ?
    – JG Cabanas
    Commented Nov 17, 2021 at 14:56
  • ES is set up and it is also the correct Version that supports 2.4.3 Commented Nov 17, 2021 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.