0

I'm trying to upgrade my Magento version from 2.3.6 to 2.4.3 and when I start I get this error:

  Problem 1
- Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.x-dev].
- Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.5.x-dev].
- Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.7.x-dev].
- Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.8.x-dev].
- Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.x-dev].
- Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.0.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.0.0, 7.11.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.0.0-beta1, 7.11.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.0.1, 7.11.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.1.0, 7.11.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.5.0, 7.11.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.5.1, 7.11.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.7.0, 7.11.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.7.1, 7.11.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.7.2, 7.11.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.8.0, 7.11.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.8.1, 7.11.x-dev].
- Can only install one of: elasticsearch/elasticsearch[v6.8.2, 7.11.x-dev].
- magento/product-community-edition 2.4.3 requires elasticsearch/elasticsearch ~7.11.0 -> satisfiable by elasticsearch/elasticsearch[7.11.x-dev].
- Installation request for magento/product-community-edition 2.4.3 -> satisfiable by magento/product-community-edition[2.4.3].
- Installation request for elasticsearch/elasticsearch ^6.0 -> satisfiable by elasticsearch/elasticsearch[6.0.x-dev, 6.5.x-dev, 6.7.x-dev, 6.8.x-dev, 6.x-dev, v6.0.0, v6.0.0-beta1, v6.0.1, v6.1.0, v6.5.0, v6.5.1, v6.7.0, v6.7.1, v6.7.2, v6.8.0, v6.8.1, v6.8.2]. 

We currently have ES version 7.6 and it's on a cloud server. And as far as I know Magento 2.3.6
ES version 7.6 should be more than enough. Does anyone know why I get this error?

Update: When i ran composer show elasticsearch:elasticsearch I got this:

name : elasticsearch/elasticsearch descrip. : PHP Client for Elasticsearch keywords : client, elasticsearch, search versions : * 6.x-dev

But our Nexcess container I have ES version 7.9

2 Answers 2

0

From magento requirements, it says for magento 2.4.3 you need ES 7.9

requirements

2
  • Updated to ES7.9 and get the same error Nov 15, 2021 at 14:57
  • I don't know nexess nor cloud i won't be able to help you more sorry. Hearing about container i guess it's something like docker; may be when you run the composer install he tries to run from your local instead of the container...which might explain the diff. Though if you are connected to the server and make a composer require of the good version i don't see why it would not work. Good luck !
    – Claims
    Nov 15, 2021 at 15:41
0

Try to match elasticsearch versions with composer.json and composer.lock with magento 2 github with the version you are upgrading

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.