0

I have recently installed a Magento 2.4.3 version and for some reason, the product images are not displaying correctly in the frontend.

The source URL in Magento is displaying: https://4youshop.online/media/catalog/producth/i/high_68271040_0971007033.jpg

the correct URL is: https://4youshop.online/media/catalog/product/h/i/high_68271040_0971007033.jpg

As you guys can see, Magento is missing the final slash after product.

We have tried multiple things:

  • Delete all cache
  • Flush all cache
  • Delete all static files
  • Regenerate all static files
  • Resize all image files
  • Set secure and unsecure URL

Please assist! Also, be aware that we have multiple storefronts and multiple store URLs. None of them seem to work and all have the same problem.

Thank you!

2 Answers 2

0
select * from core_config_data where path like '%base%url%';  

Check with this what value you are getting.

Did you add a slash at the end of Base URL in admin config interface for media setting.

5
  • Thank you for your reply. However it did work. We performed the command and the media and static files field remain empty because we have a multi store.
    – Feld.e
    Nov 7, 2021 at 8:13
  • You have to end the url with a / otherwise Magento gives a error message. We have tried the next value: {{secure_base_url}}pub/media/ That did not help. The images still do not load.
    – Feld.e
    Nov 7, 2021 at 8:14
  • It looks like your theme has not followed the standard way of get the image URL.So can you post the .phtml and the associated block class. Nov 8, 2021 at 18:54
  • Hi, we have just checked and with the Luma theme it is not working as well. That points towards a misconfiguration. Could you guys point me towards the right direction?
    – Feld.e
    Nov 10, 2021 at 14:18
  • Disable all the community module and check .Then enable module in bunch and cross check.It looks like some plugin of a module is making the code to define the image path in wrong way. Nov 11, 2021 at 18:26
0

Eventually we have decided to reinstall Magento2 due to a misconfiguration. None of the modules affected the situation. Thank you for your time!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.