0

we have Magento 2.25 and recently it stopped accepting credit cards. We were originally using authorize.net and when a user enters a credit card number it comes back with an error that says "Please enter a valid credit card type number". This error comes up right below the field where you enter the credit card number. Once you enter the number it happens immediately and does not allow you to checkout. We have tried different cards such as AMEX, Visa, and MC. Regardless of the card type, it returns an error "Please enter a valid credit card type number". At first, we thought it was an issue with the Authorize.net module so we tried different payment solutions. We tried PayPal and it also returned the same error. Any suggestions on what may be causing this issue?

Any help would be much appreciated!!

1 Answer 1

0

Make sure your payment account is not blocked due to many trials of wrong card number contact 2) Clear cache i.e php/bin magento cache:flush 3) try incognito broswer 4) Try checkout with a valid card which works on other online store for sale buy 5)close all payment method and enable only cash on delivery payment method and try checkout as money order or cash on delivery Hope this will work

Note make sure disable all custom modules

2
  • Thank you so much for getting back to me. I really appreciate it! We have cleared cache many many times and still did not fix the issue. We have tried incognito and different browsers and it still presents the same error. The credit cards that we are testing with are valid and work. We have disabled all payment methods, and that did not help too. We have also disabled custom modules and that did not fix it either. We even hired a magento developer and still he could not fix the issue. This has to be fixed somehow? I hope someone may be able to help us! Thanks so much!!!
    – nliebrand
    Oct 21, 2021 at 23:11
  • Try these commands from your server: rm -rf pub/static/*; rm -rf var/view_preprocessed/* rm -rf generated/* php bin/magento cache:flush php bin/magento setup:upgrade php bin/magento setup:di:compile php bin/magento setup:static-content:deploy -f php bin/magento indexer:reindex Hope this will resolve your issue Make sure your backup Oct 22, 2021 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.