When I try to run the composer update. I get this error.

  • elasticsearch/elasticsearch v7.11.0 requires ext-json >=1.3.7 -> the requested PHP extension json has the wrong version (7.4.24) installed. Any idea how to fix it?

I am running PHP 7.4.24 and I have php-json installed.

1 Answer 1


You cant update from 2.3.5-p1 to 2.4.3-p1 directly.

First you have to upgrade to 2.4.2

Then can change your PHP version to 7.4 and the Composer to 2.x

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.