1

a little help if possible, please. I cannot get layered navigation working with search results i.e. no filters? Works perfectly when browsing the website with all filters showing the correct results etc... I checked through the settings including the obvious "Use in search results layered navigation" which is set to "Yes" for all appropriate attributes. Any ideas??? Magento 2.4.3 | Amasty Improved layered Navigation and several others from Amasty.

1
  • Could anyone suggest how to fault find a problem like this? I assume something is blocking the filters being diplayed and would like some advice on where to look?
    – Rikgb
    Commented Oct 20, 2021 at 10:23

2 Answers 2

0

A couple of months ago I had the same issue. Make sure that default search is set to Elastic search (I used Sphinx which caused the issue). If you are on a development server you might also consider disabling Amasty Improved layered Navigation and see if layered navigation works with search results.

2
  • Thank you for the info. I have tried disabling the Amasty module but sadly it made no difference. Regarding the Elastic search setting, that is interesting? I currently use Amasty Elastic search but could try switching it back to normal?
    – Rikgb
    Commented Oct 19, 2021 at 18:51
  • No dice with the Elastic Search settings either :(
    – Rikgb
    Commented Oct 19, 2021 at 19:05
0

Set Enable Ajax to No in Amasty - Improved Layered Navigation extension. https://nimb.ws/QB4RpO

If you are using Porto Theme then disable Mageplaza Ajax & Mageplaza Layered Navigation extension.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.