I am trying to setup new project locally but can't pull any docker images, tried on old project and still same issue. tried restarting everything, re logging in docker etc. pulled docker-hello successfully.

enter image description here

but receiving following error everytime Handshake timeout

Error response from daemon: Get "https://registry-1.docker.io/v2/": net/http: TLS handshake timeout

2 Answers 2


Here are somethings that may work: check network settings (using commands </dev/tcp/registry-1.docker.io/443 && echo Works || echo Problem

curl https://registry-1.docker.io/v2/ && echo Works || echo Problem)

Did you check proxy settings in (etc/default/docker) ?

  • It returns works. I have installed docker with brew, I have nothing like etc/default docker and dockergento was working well before. Commented Sep 30, 2021 at 14:16

I think problem was related to my provider
Fixed problem using VPN

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.