0

Flat product table, once enabled should be used solely to display a product. Am I wrong ?

So, if I add attributes, how can I add these in the flat tables..?

example of a line I get on catalog_product_flat on my website:

entity_id   ;   268232
attribute_set_id    ;   9
type_id ;   simple
availability_titelive   ;   6
cost    ;   NULL
created_at  ;   08/05/2014 13:55
credit_amount   ;   NULL
enable_googlecheckout   ;   1
fb_product  ;   NULL
gift_message_available  ;   NULL
has_options ;   0
image_label ;   NULL
is_recurring    ;   NULL
links_exist ;   NULL
links_purchased_separately  ;   NULL
links_title ;   NULL
msrp    ;   NULL
msrp_display_actual_price_type  ;   NULL
msrp_enabled    ;   NULL
name    ;   

Mon Bloc De Dessin 3d &#59; Special Filles
news_from_date  ;   NULL
news_to_date    ;   NULL
price   ;   130.0000
price_type  ;   NULL
price_view  ;   NULL
publication_date_titelive   ;   01/12/2015 00:00
recurring_profile   ;   NULL
required_options    ;   0
shipment_type   ;   NULL
short_description   ;   

Une nouvelle collection de kits totalement inédite

 avec tout le matériel pour créer des&#32

;images en 3 dimensions &#
sku ;   9782215109372
sku_type    ;   NULL
small_image ;   NULL
small_image_label   ;   NULL
special_from_date   ;   NULL
special_price   ;   NULL
special_to_date ;   NULL
tax_class_id    ;   0
thumbnail   ;   NULL
thumbnail_label ;   NULL
updated_at  ;   02/09/2014 16:57
url_key ;   mon-bloc-de-dessin-3d-special-filles
url_path    ;   mon-bloc-de-dessin-3d-special-filles.html
visibility  ;   4
weight  ;   283.0000
weight_type ;   NULL

etc..What I infer from this is the flat table isn't correctly getting all the

new attributes I added. And (since the product page displays correctly that

magento will look for what is missing using INNER JOIN). Great but best would

be that all fields are correctly fed.

Thanks for your help.

Mat

1

Attributes should be added to the table automatically when they have "Use in product listing" set. Certain attribute types cannot be added to the table, like multi-select lists.

2
  • In the admin panel, Catalog > Attributes > Manage Attributes > Click on an attribute > Use in product listing Mar 21 '15 at 19:02
  • @clockworkgeek I have a small query i have observed "ts_dimensions_width" attribute contains "Used in Product Listing" configured as "No" by default M2.3.1, but this attribute has been populated in the table "catalog_product_flat_1" is there any idea? please advise
    – Nagaraju K
    Jul 11 '19 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.