0

I got a small problem when compiling magento,i.e,

C:\xampp\htdocs\magento-ce-2.4.1-2020-09-25-04-08-02>php -dmemory_limit=4G bin/magento setup:di:compile Compilation was started. Plugin list generation... 8/9 [========================>---] 88% 2 mins 382.0 MiB

In ErrorHandler.php line 61:

Warning: Use of undefined constant ‘ - assumed '‘' (this will throw an Error in a future version of PHP) in C:\xampp\htdocs\magento-ce-2.4.1-2020-09-25-04-08-02\ve ndor\magento\framework\Interception\PluginListGenerator.php on line 159

i have replaced from $cacheId = implode('|', $this->scopePriorityScheme) . "|" . $this->cacheId; to $cacheId = implode(‘-’, $this->scopePriorityScheme) . “-” . $this->cacheId;

Using materials:-

magento 2.4.1

xampp/php 7.4.23

elasticsearch 7.6.0

Thanks

2
0

In your magento's root "error_log" or "php_error" file.

here please check what's error in your code

7
  • if not in root than its in php's error log path. depend on server configuratiion Sep 24 at 4:45
  • I upgraded system php 7.3.5 to 7.4.25....now its resolved. after completing the magento setup through command prompt...I got deprecated error while running localhost on google , like localhost:82/magento/admin its showing below error like this Deprecated: The behavior of unparenthesized expressions containing both '.' and '+'/'-' will change in PHP 8: '+'/'-' will take a higher precedence in C:\xampp\htdocs\magento\vendor\magento\framework\Interception\PluginListGenerator.php on line 161 Sep 27 at 6:52
  • happy to hear it's resolved Sep 27 at 6:59
  • you know the deprecated error. Sep 27 at 7:11
  • your any custom module's plugin must be using depracated method. please check custom modules Sep 27 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.