0

Categories do not load when I am editing a product, I can't even select them. The customer changed the url of the category and then this error occurred. Any suggestions?

enter image description here

3
  • Try doing a reindex from CLI. I've seen this happen in Magento 1, but it was a 3rd party module causing the categories to mess up. Might be worth disabling any modules you've added if you havent already tried that.
    – Chris
    Sep 15 at 9:32
  • Thank you, but still doesn't work. Sep 15 at 10:58
  • I'm having the same problem, my version is 2.4.2 and I still haven't found a suitable solution.
    – Lancer
    Sep 23 at 3:22
1

First! confirm your store is in an local envrionment, Use below SQL to Reset Database Category data;

SET FOREIGN_KEY_CHECKS = 1;

TRUNCATE TABLE catalog_category_entity;
TRUNCATE TABLE catalog_category_entity_datetime;
TRUNCATE TABLE catalog_category_entity_decimal;
TRUNCATE TABLE catalog_category_entity_int;
TRUNCATE TABLE catalog_category_entity_text;
TRUNCATE TABLE catalog_category_entity_varchar;
TRUNCATE TABLE catalog_category_product;
TRUNCATE TABLE catalog_category_product_index;

INSERT INTO `catalog_category_entity` (`entity_id`, `attribute_set_id`, 
`parent_id`, `created_at`, `updated_at`, `path`, `position`, `level`, 
`children_count`) VALUES ('1', '0', '0', CURRENT_TIMESTAMP, 
CURRENT_TIMESTAMP, '1', '0', '0', '1'),
('2', '3', '1', CURRENT_TIMESTAMP, CURRENT_TIMESTAMP, '1/2', '1', '1', 
'0');

INSERT INTO `catalog_category_entity_int` (`value_id`, `attribute_id`, 
`store_id`, `entity_id`, `value`) VALUES 
('1', '69', '0', '1', '1'),
('2', '46', '0', '2', '1'),
('3', '69', '0', '2', '1');

INSERT INTO `catalog_category_entity_varchar` (`value_id`, `attribute_id`, 
`store_id`, `entity_id`, `value`) VALUES 
('1', '45', '0', '1', 'Root Catalog'),
('2', '45', '0', '2', 'Default Category');

SET FOREIGN_KEY_CHECKS = 1;
1
  • I have a lot of categories and I don't want to reset the categories, I just want to know what is the reason for this happening? And how to fix the problem?
    – Lancer
    2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.