0

Im facing this issue in magento 2.3.7 that my site is getting load in 5-10 mins. after restating the server its working fine but again in every 1 hour its going down like this when i try to look in logs. this error is constantly hitting while loading the site when

The store that was requested wasn't found. Verify the store and try again. {"exception":"[object] (Magento\\Framework\\Exception\\NoSuchEntityException(code: 0): The store that was requested wasn't found. Verify the store and try again. at /home/h1/public_html/vendor/magento/module-store/Model/StoreRepository.php:112)"} []

Please help me to get this resolve because of this site is going slow again and again in every hour .

Thanks in Advance :)

3 Answers 3

1

It look either you have misconfiguration in stores or one of theme is causing the issue.Can you share more details on it from log file.

0

It's an error in server configuration. Your server Nginx or apache 2 sends incorrect store_code to PHP. There is param $MAGE_RUN_CODE in the site configuration. Add var_dump($_SERVER); in your index.php . You have to change store code in MySQL DB or in a site configuration file.

0

Please add the correct storecode within your nginx configuration file.

Another way is to add the correct store id within your index.php file as it's leading. I would however use the nginx way, as it's recommended by my host.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.