0

I wanted to put my shop live on wednesday last week. Due to problems from my hoster, this was not possible, so it went live on thursday instead. When it was live, I encountered a problem with the purchase Button. It wasn't working anymore. (In my local version everything works fine). After Debugging for several hours, trying to fix the issue, I at the end thought, maybe this was a server problem (given the fact that the server was down the day before). When calling the support center I let the support do a test purchase. She told me what she was doing and then clicked purchase and "poooff" the purchase went through. I didn't do anything so wtf!?! Anyways I was happy that it worked. Until yesterday! Around 5pm I guess, cause I got a call from a client, that the purchase button is not working. Till 10.30am everything still worked, cause there were purchases made. Calling support center this time, unfortunately didn't have the same effect as yesterday.

I did some minor bugfixing yesterday (CSS stuff). Other things I undid. I have no clue, what went wrong at some point. I don't get error messages, at least none where I would think they have something to do with the purchase button not working. On my local version everything works! Compared the files, they are the same. I'm not a pro, so my debugging skills are limited.

Could someone please take a look at the page and make a test purchase? The site is in german so please click at a dish, choose a date, and click in den warenkorb. After this click "zur kasse" and fill in some dummy data click "weiter", choose "auf rechnung, click "weiter". At the review check the two boxes. And click "kaufen".

Usually you should be forwarded to success page, but now just the loadie is shown and nothing happens. Can someone point me in the right direction here? I am searching for hours now and I don't have a promising lead yet.

Update

Log from Purchase Button click

Could this cause the issue? The cookies are already expired, because the server ist 2 hours behind? I changed the cookie expire date to 86400 but that didn't help. So I think I would have to change the date on server.

11
  • Have you been testing across a number of different browsers? – Jonathan Hussey Sep 4 '14 at 8:16
  • Yes, all are not working. Chrome, Firefxox, IE, Opera and Safari. – user3432078 Sep 4 '14 at 8:23
  • Ok, and what about things like is the caching enabled/disabled status the same between the local and production install? Try and determine what differences exist between the setups both in terms of admin settings and server setup. If you are confident the code base is identical between the two then it can only really be database differences or server setup. – Jonathan Hussey Sep 4 '14 at 8:45
  • is there a way to use the repair database tool from magento with 1.8? I tried it but it didn't work. I got the following error: "Corrupted database doesn't support InnoDB storage engine". Is there an alternative? – user3432078 Sep 4 '14 at 9:05
  • Do you have good reason to believe the database may be at fault? In situations like this it's not a good idea to just to try things for the sake of it. Try and debug the problem otherwise you may well end up just digging a bigger hole for yourself. – Jonathan Hussey Sep 4 '14 at 9:12
0

Purchase Button is working again. I'm not really sure, what exactly caused the issue, but changing Payment Method did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.