3

I am looking to upgrade my Magento Store from 2.4.2 to 2.4.3. When I enter the command "composer update" I get the below response.

Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires magento/product-community-edition 2.4.3 -> satisfiable by magento/product-community-edition[2.4.3].
    - Conclusion: don't install league/flysystem 1.1.0 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.2 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.3 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.4 (conflict analysis result)
    - Conclusion: don't install league/flysystem 1.1.1 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.5 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.6 (conflict analysis result)
    - Conclusion: don't install league/flysystem 1.1.2 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.7 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.0.8 (conflict analysis result)
    - Conclusion: don't install league/flysystem 1.1.3 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.1.0 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.1.1 (conflict analysis result)
    - Conclusion: don't install league/flysystem 1.1.4 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.2.0 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.2.1 (conflict analysis result)
    - Conclusion: don't install league/flysystem 1.1.5 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.2.2 (conflict analysis result)
    - Conclusion: don't install league/flysystem 2.2.3 (conflict analysis result)
    - csharpru/vault-php 3.5.3 requires cache/cache ^0.4.0 -> satisfiable by cache/cache[0.4.0].
    - magento/magento2-functional-testing-framework 3.1.0 requires csharpru/vault-php ~3.5.3 -> satisfiable by csharpru/vault-php[3.5.3].
    - magento/product-community-edition 2.4.3 requires magento/module-aws-s3 100.4.1 -> satisfiable by magento/module-aws-s3[100.4.1].
    - Root composer.json requires magento/magento2-functional-testing-framework 3.1.0 -> satisfiable by magento/magento2-functional-testing-framework[3.1.0].
    - cache/cache 0.4.0 requires league/flysystem ^1.0 -> satisfiable by league/flysystem[1.0.0, ..., 1.1.5].
    - You can only install one version of a package, so only one of these can be installed: league/flysystem[1.0.0, ..., 1.1.5, 2.0.0, ..., 2.2.3].
    - magento/module-aws-s3 100.4.1 requires league/flysystem ^2.0 -> satisfiable by league/flysystem[2.0.0, ..., 2.2.3].
    - Conclusion: don't install league/flysystem 2.0.1 (conflict analysis result)

My reading of this is I have 2 modules that require a different versions of league/flysystem

  • cache/cache 0.4.0 requires league/flysystem 1.X
  • magento/module-aws-s3 100.4.1 requires league/flysystem 2.X

How do I resolve this?

My composer.json file is here:

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "config": {
        "preferred-install": "dist",
        "sort-packages": true
    },
    "require": {
        "magento/composer-dependency-version-audit-plugin": "~0.1",
        "magento/composer-root-update-plugin": "~1.1",
        "magento/product-community-edition": "2.4.3",
        "tnw/module-stripe": "^2.1"
    },
    "require-dev": {
        "friendsofphp/php-cs-fixer": "~2.18.1",
        "lusitanian/oauth": "~0.8.10",
        "magento/magento2-functional-testing-framework": "3.1.0",
        "pdepend/pdepend": "2.5.2",
        "phpmd/phpmd": "@stable",
        "phpunit/phpunit": "~6.5.0",
        "sebastian/phpcpd": "~3.0.0",
        "squizlabs/php_codesniffer": "3.3.1",
        "symfony/finder": "^5.2"
    },
    "conflict": {
        "gene/bluefoot": "*"
    },
    "autoload": {
        "psr-4": {
            "Magento\\Framework\\": "lib/internal/Magento/Framework/",
            "Magento\\Setup\\": "setup/src/Magento/Setup/",
            "Magento\\": "app/code/Magento/"
        },
        "psr-0": {
            "": [
                "app/code/",
                "generated/code/"
            ]
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ],
        "exclude-from-classmap": [
            "**/dev/**",
            "**/update/**",
            "**/Test/**"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\\Tools\\": "dev/tools/Magento/Tools/",
            "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "version": "2.3.0",
    "minimum-stability": "stable",
    "repositories": {
        "0": {
            "type": "composer",
            "url": "https://repo.magento.com/"
        },
        "magesycho-magento2-custom-shipping": {
            "type": "git",
            "url": "git@github.com:MagePsycho/magento2-custom-shipping.git"
        }
    },
    "extra": {
        "magento-force": "override"
    }
}
4
4

In composer.json try to change version of 'magento2-functional-testing-framework':

from magento/magento2-functional-testing-framework": "3.1.0

to magento/magento2-functional-testing-framework": "3.*

then composer update

1
  • Thank you. This worked perfectly.
    – brettstix
    Sep 14 '21 at 11:03
1

I solved this problem by downloading the Magento 2.4.3 release as a zip download from the Magento site, and opening up the composer.json file. I then copied the programs in the "require-dev": section to the composer.json file in my Magento, and then Magento would upgrade.

0

Try

composer require magento/product-community-edition=2.4.3 --no-update --use-default-magento-values

--use-default-magento-values this will update the composer json as per the default magento values

then,

composer update

1
  • This outputs this - [Symfony\Component\Console\Exception\RuntimeException] The "--use-default-magento-values" option does not exist.
    – MagentoMac
    Nov 17 '21 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.