0
Magento 2.4.2-p1
Porto theme
Amasty's Email settings extension

We installed Magento 2.4.2-p1, then the Smartwave Porto theme and then we had Amasty install 9 extensions including SMTP Email Settings for Magento 2. I have setup the cron job which was confirmed set up correctly and working by our hosting company. I then configured Amasty's Email settings extension but it does not work = no Order Confirmation Emails go out. I have created a ticket with Amasty but they are taking very long to do anything and have just recently turned this over to their Developer who apparently uninstalled the SMTP Email Settings extension as I no longer see it on the back end (Admin panel) of Magento.

Previously, when I tested the SMTP Email Settings extension through a test button they have on the bottom - it confirmed the Email settings I put in there are valid and actually sent a test Email out which I received in my Email Inbox.

My hosting company responded with the following:

We have been testing and monitoring the logs of the Exim mail service and what appears to be happening is that an SMTP connection is not made at all when an order is placed. This means that the issue is not caused by failed authentication because an authentication attempt is not made at all. PHP mail is also not being used as no activity is logged at all when the order confirmation email should be sent. Since the SMTP plugin is working correctly when a test mail is sent, I would recommend contacting Amasty who will be able to provide you more information on why an order confirmation email is not sent. Do let us know If any server-side changes have to be made to resolve this issue .

What would be the normal way to set up in Magento 2 to send out Order Confirmation Emails without an extension such as Amasty's?

I found the following:

Stores -> Configuration -> Advanced -> System

We currently have the following in there:

Disable Email Communications = NO 
Host: Our mail host 
Port (25) = 25

I know it had like localhost in there before. Should I change it back to localhost and how would the Sending of the (outgoing) Emails even get authenticated this way? Is there any other test I can try to do or set up differently?

0

The normal way to set up in Magento 2 to send out Order Confirmation Emails without an extension such as Amasty

Stores -> Configuration -> Advanced -> System

Under Mail Sending Settings make sure - Disable Email Communications is set to No.

Also verify your Host and Port fields if you are using any external mailing server.

Stores -> Configuration -> Sales -> Sales Emails

Under General Settings tab, choose Asynchronous sending to Disable

Under Order tab Enabled to Yes

1
  • I have this set up exactly as you wrote except in the host name field under Stores -> Configuration -> Advanced -> System I have an actual host name filled in even though it's not an external mailing server (does it suppose to say localhost?). My question is how does the outgoing mail get authenticated since most outgoing mail out there nowadays require authentication? Or is there a way for me to set up an Email account without sending authentication?
    – Allysin
    Sep 6 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.