2

I am upgrading Magento 2.4.2 to 2.4.3

on composer update I am facing these issues

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install ramsey/uuid 4.1.1
    - Installation request for magento/magento2-functional-testing-framework ^3.0 -> satisfiable by magento/magento2-functional-testing-framework[3.0.0, 3.1.0, 3.1.1, 3.2.0, 3.2.1, 3.3.0, 3.4.0, 3.5.0, 3.5.1, 3.6.0, 3.6.1].
    - Installation request for allure-framework/allure-phpunit ~1.2.0 -> satisfiable by allure-framework/allure-phpunit[1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4].
    - magento/product-enterprise-edition 2.4.3 requires ramsey/uuid ~4.1.0 -> satisfiable by ramsey/uuid[4.1.0, 4.1.1].
    - magento/product-enterprise-edition 2.4.3 requires ramsey/uuid ~4.1.0 -> satisfiable by ramsey/uuid[4.1.0, 4.1.1].
    - Conclusion: don't install ramsey/uuid 4.1.0
    - Installation request for magento/product-enterprise-edition 2.4.3 -> satisfiable by magento/product-enterprise-edition[2.4.3].

any way to fix it ?

2
  • I think I had this one. Do you have a replace section at the bottom of the composer.json? Try removing it. Sep 3 at 8:13
  • No i have not replace or edit composer.json Sep 3 at 8:23
1

Check composer version if its not 2 then update it. Magento 2.4.3 requires 2.x composer version.

sudo composer self-update --2

composer install
2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.