7

I upgraded my site from Magento 2.4.2 to 2.4.3, and now frontend is ok, but backend very slow. 2.4.2 was fine. Still to see warnings -

Attention

Something went wrong.

A technical problem with the server created an error. Try again to continue what you were doing. If the problem persists, try again later.

Invalid security or form key. Please refresh the page.

indexer, cache and cookies cleaning doesn't help.

Any idea?

1
  • bin/magento config:set system/security/max_session_size_admin 0 This code is usefully for me @iskander Thankyou Feb 21, 2022 at 9:43

3 Answers 3

10

Solved, i found the solution here - https://github.com/magento/magento2/issues/33748

bin/magento config:set system/security/max_session_size_admin 0

work for me

1
  • Link is broken. Any chance of detailing what's going on here?
    – gnicko
    Feb 8, 2022 at 20:50
9

This new value is added to Magento 2.4.3 in vendor/magento/module-security/etc/config.xml. There, the initial value is set to 256000. I find it a bit extreme to set it directly to 0. At least in our case 512000 was enough to solve the issue and still keep the idea of this setting.

1
  • If that setting is security related I don't think it was in the mind of the developers to just set it down to 0 if any error occurs. To find the right value I would like to understand what that setting is exactly doing? As i understood other solutions they're using session tracking to limit the number of sessions by a specific IP. What's the idea of that setting you're talking about in Magento? Am I blind or is this new setting/function missing in the 2.4.3 changelog?
    – Sebastian
    Apr 4, 2022 at 13:34
0

Before you update! Change "Max Session Size in Admin" value from 256000 to 512000 in backend panel. You can find it in Stores > Configuration > Advanced > System > Security. It solves also 2FA login problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.