0

I have deployed the magento website using bitnami magento stack on Azure platform. Also for security I have included this in VPN and connect to the server(SSH) via VPN client.

Even after all magento services are running properly on the server I cannot access the magento website via internet and its redirecting the server public IP to the VPN server IP. Summary: enter link description here
I used the above link to create server on Azure using the predefined template provided. It already has Magento, apache, Mariadb, varnish, PHP, etc preinstalled. We just have to run the master script and start all the services and can access it via browser. Also please note that the server is inside a VPN network so inorder to connect to server or its deployed webapps I have to connect to VPN using VPN client.

Now the issue is its whenever I tried to access the magento website via server's public ip its showing http status 302 in the apache access log.

enter image description here

Also I tried the following:
    a. running a separate node server on the same magento server on 80 port and it was accessible via browser.
    b. Deployed a similar bitnami stack magento server just without the VPN and it was accessible via internet.
    

Do we have to do any extra configurations in Apache/other services when using a VPN ?

Kindly help me out in this.

4
  • When you say "deployed" did you post an image or you went through the installation of magento and now its just not accessible? I suggest you create a php file with "hello world" text in the root of the installation and see if you can access it directly. If you cannot then its a web server issue - if you can please provide more details.
    – SR_Magento
    Aug 15, 2021 at 15:55
  • bitnami.com/stack/magento I used the following link to create server on Azure using the template provided. It already has magento, apache, mariadb, varnish, php,etx preinstalled. We just have to run the master script and start all the services. Aug 16, 2021 at 4:29
  • @SR_Magento Also please note that the server is inside a VPN network so inorder to connect to server or its deployed webapps I have to connect to VPN using VPN client. Now the issue is its whenever I tried to access the magento website via server's public ip its showing http status 302 in the apache access log Aug 16, 2021 at 4:43
  • @SR_Magento Also I tried the following: a. running a separate node server on the same magento server on 80 port and it was accessible via browser. b. Deployed a similar bitnami stack magento server just without the VPN and it was accessible via internet. Do we have to do any extra configurations in Apache/other services when using a VPN? Aug 16, 2021 at 4:43

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.