0

Magento CE 2.3.2

Uploaded new image and set base, small and thumbnail that image save product navigate on category page for that product image not showing and open image path in new tab , image not found but when open product in new tab, it showing that image on product detail page. I also open path in new tab it working and showing image. compare both category page product image path and product page image path both are same.

So for I have done

php bin/magento setup:upgrade

php bin/magento s:d:c

php bin/magento s:s:d

php bin/magento indexer:reindex

chmod -R 777 pub/ var/

4
  • you are missing the deploy command. I would do this sequence: bin/magento setup:upgrade bin/magento setup:static-content:deploy bin/magento setup:di:compile bin/magento indexer:reindex bin/magento catalog:images:resize bin/magento cache:flush bin/magento cache:clean Aug 10, 2021 at 14:42
  • I have done with all mentioned commands except bin/magento catalog:images:resize this command shows image does not exist in some directories.
    – ishaq
    Aug 10, 2021 at 16:33
  • Issue is resolved now there was missing .htaccess file inside pub/media
    – ishaq
    Aug 10, 2021 at 17:33
  • great! thanks for sharing the solution. Aug 11, 2021 at 0:32

1 Answer 1

0

you are missing the deploy command. I would do this sequence:

  • bin/magento setup:upgrade
  • bin/magento setup:static-content:deploy -f
  • bin/magento setup:di:compile
  • bin/magento indexer:reindex
  • bin/magento catalog:images:resize
  • bin/magento cache:flush
  • bin/magento cache:clean

Please note that deploy command shall include the languages your website has on all language folders... like en_US -f if in English, pt_BR -f if in portuguese

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.