0

Magento newbie here, learning the platform by following a tutorial. I use magento 1.9.3.2. I have looked at all other posts relating this problem and yet it persists. I'm creating a simple menu in admin panel and get the error above. Here's some code: app\etc\modules\Akhil_News.xml

<?xml version="1.0"?>
    <config>
    <modules>
      <Akhil_News>
        <active>true</active>
        <codePool>local</codePool>
      </Akhil_News>
    </modules>
</config>

And config.xml in app\code\local\Akhil\News\etc

<?xml version="1.0"?>
<config>
    <modules>
        <Akhil_News>
            <version>0.0.1</version>
        </Akhil_News>
    </modules>
    <global>
        <helpers>
            <news>
                <class>Akhil_News_Helper</class>
            </news>
        </helpers>
        <resources>
            <news_setup>
                <setup>
                    <module>Akhil_News</module>
                </setup>
                <connection>
                    <use>core_setup</use>
                </connection>
            </news_setup>
            <news_write>
                <connection>
                    <use>core_write</use>
                </connection>
            </news_write>
            <news_read>
                <connection>
                    <use>core_read</use>
                </connection>
            </news_read>
        </resources>
    </global>
</config>

The admin html in app\code\local\Akhil\News\etc

<?xml version="1.0" encoding="UTF-8"?>
<config>
    <menu>
        <news module="akhil_news" >
            <title>News</title>
            <sort_order>100</sort_order>
            <children>
                <managenews module="akhil_news">
                    <title>Manage News</title>
                    <sort_order>90</sort_order>
                    <action>admin_news/adminhtml_news</action>
                </managenews>
            </children>
        </news>
    </menu>
</config>

And finally the helper class app\code\local\Akhil\News\Helper\Data.php

 <?php
    
     class Akhil_News_Helper_Data extends Mage_Core_Helper_Abstract
     {
        
     }
?> 

These files should give me a menu with no functionality in admin panel. However the entire admin is throwing this error. I have looked at other posts and, 1.Compilation is disabled 2.Cleared the cache multiple times 3.Most other posts solutions were closing tags or naming of the class.

If I set in app\etc\modules\Akhil_News.xml the module to false, I get a normal page load so I believe the mistakes is in one of the config files but I'm unable to find it so far.

1 Answer 1

0

Try to do following ways.

  1. Do the caching and indexing one's.

  2. Do the "Compilation" one's from admin.

NOTE: Before compilation, please take the backup of website.

2
  • I deleted all files and refreshed the indexes and cleared the cache. Then put the files back in and now it's fine. I guess it was the indexing because I didn't refresh it until now?
    – iivo
    Aug 9, 2021 at 8:57
  • Yes some time caching or reindexing create this type of issues. Aug 9, 2021 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.