1

Magento 1.9 CE running on LAMP stack.

Users land on site initially and they are getting Magento's "please enable use of cookies" page. They refresh and it is gone. I confirmed this behavior for Chrome and Safari.

Some are saying this is the solution to prevent it: Go to System –> Configuration –> General –> Web –> Session Cookie Management –> Cookie Lifetime = 5400

However my cookie lifetime was already set much higher than that and if you refresh even once the cookie is gone - changing cookie lifetime is not the fix.

I know how to turn it off: Go to System –> Configuration –> General –> Web –> Browser Capabilities Detection –> Redirect to CMS-page if cookies are disabled = No

But I'm most interested in what is actually causing it.

  • Is this a public or a local install? – brentwpeterson Sep 2 '14 at 16:24
  • Public install. – sparecycle Sep 2 '14 at 16:25
  • Have you tested saving your sessions to the DB instead of files? – brentwpeterson Sep 2 '14 at 16:30
  • No but I will. Doesn't that imply that there might be an issue writing sessions to the server? – sparecycle Sep 2 '14 at 16:36
  • I've edited my answer with new things – versedi Dec 11 '14 at 17:15
3
  1. Check if time (date and timezone as well) are set correctly on your server.
  2. Check if Base URL of your installation is set correctly at System > Configuration > Web
  3. Check if your sessions can be saved on filesystem or in DB. Open app/etc/local.xml file and look for <sessions> section, it is either set to files or db. Make sure that files can be written under var/session or in database and there is enough disk space or inodes.
  4. If you use any third-party caching extension (turpentine or FPC or cache extensions that utilize varnish etc.), try disabling these extensions. To completely disable extension edit its XML config in app/etc/modules/Extension.xml and change <active> tag to false.
| improve this answer | |
1

You can use this free extension it can help you easily

https://www.webinse.com/magento2-cookie-alert
| improve this answer | |
0

If you are using a localsetup then you can try out this:

enable cookies issue in chrome and safari

This solved my problem also i was facing an issue with admin login in chrome, this solved it too. You won't have to do anything else.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.