0

I am struggling with minicart item template file located at:

app/design/frontend/vendor/theme/Magento_Checkout/web/template/minicart/item

filename: default.html

any changed I make to this file are not reflecting to it, even tried editing the same file in vendor/magento folder too, but the result is same.

Already deleted all pre generated and cached files using command

rm -rf pub/static/frontend/* pub/static/adminhtml/* var/cache/ var/generation/ var/page_cache/ var/view_preprocessed/ generated/

also cleared all magento cache using admin and commands to clean and flush cache, cleared browser cache, tried incognito mode, even tried in a browser in which I never visited the website.

Am I missing something ?


I haver even confirmed that I can see my code changes at deployed file:

pub\static\frontend\vendor\theme\en_US\Magento_Checkout\template\minicart\item\default.html

Also verified that there is no server side or CDN cache applied to files. Even tried running website with host entry to by pass any cache and all request to hit directly to server.

1
  • Hi, Please check in your custom modules same file is override or not and also check the for minicart block set the another template file or not. Aug 6, 2021 at 5:10

3 Answers 3

1

Use content deploy command and check the result

1
  • already tried multiple times, as I was deleting all the files using rm command I will have to deploy content. Aug 6, 2021 at 4:57
0

In case you haven't, try directly refreshing the file in your browser cache. You can do this by just calling up the direct URL of the file and CTRL+F5.

Magento sets some pretty agressive cache headers for the static files so even if you refresh the page you're working on without cache the static files tend to get cached anyway

0

Please make sure you are in development mode. Then use the cache clear and deployment command. It also didn't work means please disable your block_html and FPC cache in the admin panel and check the change is working and don't forget to check that your template file is in the correct path at your child theme.

If not work please do the setup:upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.