19

What are the mapping of CE/PE/EE versions to corresponding Zend versions?

If possible I need a list going back before Magento 1.1.

1 Answer 1

26

Here is what I have. I hope it's enough. Because PE and EE versions can be related to CE versions I think you can figure out the missing values.

CE 1.0.19870.4 - ZF 1.5.1
CE 1.1.6 - ZF 1.5.1
CE 1.2.0.1 - ZF 1.7.2
CE 1.3.2.1 - ZF 1.7.2
CE 1.4.0.1 - ZF 1.9.6
CE 1.4.2.0 - ZF 1.10.8
CE 1.5 - CE 1.8 - ZF 1.11.1
CE 1.9 - ZF 1.12.3
CE 1.9.1.2 - ZF 1.12.10

PE 1.10 - ZF 1.11.1
PE 1.11 - ZF 1.11.1

EE 1.9.1.1 - ZF 1.10.8
EE 1.10 - 1.13 - ZF 1.11.1 EE 1.14 - ZF 1.12.3

[EDIT]
To get the ZF version of your Magento instance look in the file lib/Zend/Version.php.
The class constant VERSION is what you are looking for.

8
  • @Marius — what was your methodology for determining zend framework version? Commented May 3, 2013 at 16:04
  • I'm curious of that, too. This is way more comprehensive than I could come up with.
    – philwinkle
    Commented May 3, 2013 at 20:09
  • 3
    There is no methodology. I have archives with the Magento versions listed in the answer. And I took a look in the file lib/Zend/Version.php. Zend_Version::VERSION gives you the ZF version.
    – Marius
    Commented May 3, 2013 at 20:22
  • CE 1.3.2.4 ZF 1.7.2
    – Mufaddal
    Commented May 4, 2013 at 12:27
  • CE 1.8.1.0 ZF 1.11.1 Commented Jan 3, 2014 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.