0

I want to insert a iframe to my domain page, when I iframe a magento home-page, i get blank page. for example: my domain is www.a.com, I put this code on my page:

<iframe frameborder="no" style="height: 100%; width: 100%; top: 0px; bottom: 0px; position: absolute;" src="http://www.b.com"></iframe>

enter image description here

I want iframe the domain "b.com" content. but I get a blank page.

additional: a.com is bulid in zencart, b.com is build in magento. I guess it is the cms Loading problem, but I do not know how to solve. Can you help me?

I asked somebody they only said that, the magento cms page can only load once,so when iframe a magento page I get a blank page.. I need to writte the magento cms-page code to the temple. Is it right?

  • Let me clarify; you are trying to embed a magento store into a Zencart page via an iFrame, is that correct? If so, I believe this to be a Zencart issue, rather than a Magento one; please correct me if I'm wrong. – Dan Hanly Sep 2 '14 at 11:08
  • I donot thinck this to be a Zencart issue, zencart can iframe all other page, but ONLY the magento domain page – Wuqiang Gao Sep 3 '14 at 0:49
  • This is CORS problem. You can use a proxy to solve the issue. – Raptor Oct 13 '14 at 7:31
1

Its not possible to had an Iframe in the HEAD of the page.

Iframes are part of the BODY

Try this

<html>
<head>...</head>
<body>
<iframe>...</iframe>
...
</body>
</html>

I think its possible to integrate any site on other site by frames...BUT its a DIRTY WAY...

  • thanks to reply to me,but it does't work. – Wuqiang Gao Sep 3 '14 at 1:11
  • Could you please post your new code ? – Cédric Campoy Sep 3 '14 at 7:31
  • the code do not work, I need to writte the magento cms-page code to the temple. but I do not know how. – Wuqiang Gao Sep 3 '14 at 9:14
  • In your html_header.php file, do you see a <body>, just after put your <iframe> code – Cédric Campoy Sep 3 '14 at 9:54
  • I just discover a new thing in the last version of magento : see the response on that thread...it could help you... magento.stackexchange.com/questions/26267/… – Cédric Campoy Sep 3 '14 at 11:57
0

Magento has special setting to allow / disable iframe

Login to admin panel navigate to System > Configuration Open Admin section from the Advanced tabs Expand the Security panel and update “Allow Magento Frontend to run in frame” parameter.

Check this article - http://nwdthemes.com/2014/10/05/magento-not-working-in-iframe/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.