0

I have installed Magento 2.4.3 via composer and trying to install custom frontend/admin theme and custom modules. These modules are already working in version 2.3 that have been copied and added at below path

Frontend Theme - C:/xampp/htdocs/myproject/app/design/frontend/NameSpace/FrontTheme

Backend Theme - C:/xampp/htdocs/myproject/app/design/adminhtml/NameSpace/AdminTheme

Custom Module - C:/xampp/htdocs/myproject/app/code/NameSpace/MyModule

Executed commands as below

php bin/magento indexer:reindex
php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy -f
php bin/magento cache:flush

However, it is showing Nothing to import message. Also the module entry could not be seen in the table setup_module and the frontend looks like below. Moreover the admin panel in inaccessible.

enter image description here

enter image description here

Has the module installation method changed from version 2.4.3 or do I need to update my composer file in order to install local modules (not marketplace/third party modules)?

P.S. - I had first installed the backend theme and did not see anything imported so I installed frontend theme but no luck. To verify if modules are correctly installed, I later installed custom module but that as well did not show entry in setup_module table

Upon console review - it says page not found for the url - http://localhost/myproject/pub/static/version1627395423/frontend/_view/en_US/mage/calendar.css

4
  • Have a look in your browser console and see what the errors are.
    – zigojacko
    Jul 27 at 14:34
  • You should also do one thing at a time so you can pinpoint what causes the error. Like just install the frontend theme first, and see if that works. Then backend theme, see if that works. Then add your modules, check they work. We're not going to have a clue where the issue lies from what you've posted above.
    – zigojacko
    Jul 27 at 14:36
  • @zigojacko - Question updated. Jul 27 at 14:40
  • Try this answer already posted... And then let us know if it makes a difference.
    – zigojacko
    Jul 28 at 8:16
0

Try to run this commands.

php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f 
php bin/magento cache:flush 
chmod -R 777 generated var pub
0

Please run the below commands

Remove the generated files in the pu/static folder

 sudo   rm -rf var/di/* var/generation/* var/cache/* var/log/* var/page_cache/* var/session/* var/view_preprocessed/* pub/static/* generated/*

Generate the new files under pub/static

php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f 

If the above doesn't work please check the theme table and change the active theme type as 0 and execute the above command once again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.