0

I tried to login through admin panel for one of my Magento site but it is showing error as

ERROR for site owner: Invalid key type - recaptcha and not able to login.

enter image description here

Actually I changed the google recaptcha keys values of existing project from v2 to v3 for contact page after that only I am not able to login.

Also customer view of the site is also blank

Please help to overcome this issue as I am new to magento.

1 Answer 1

0

Try disable this captcha from terminal, this is the command

To Disable admin login captcha

php bin/magento config:set admin/captcha/enable 0

To Disable frontend captcha

php bin/magento config:set customer/captcha/enable 0
4
  • I tried above i am getting error as below. The XML in file "/app/code/Plazathemes/Themeoptions/etc/adminhtml/system.xml" is invalid: Element 'resource': [facet 'pattern'] The value 'plazathemes_themeoptions::config' is not accepted by the pattern '([A-Z]+[a-zA-Z0-9]{1,}){1,}_[A-Z]+[A-Z0-9a-z]{1,}::[A-Za-z_0-9]{1,}'. Line: 16 Element 'resource': 'plazathemes_themeoptions::config' is not a valid value of the atomic type 'typeAclResourceId'. Line: 16 Verify the XML and try again.
    – Sabin
    Jul 16, 2021 at 10:27
  • After changing the plazathemes_themeoptions::config as Plazatheme_Themeoptions::config above error got fixed. And i run config:set admin/captcha enable 0 and cache:flush then also i get ERROR for site owner: Invalid key type
    – Sabin
    Jul 16, 2021 at 11:06
  • Bug got fixed when I changed MSP_ReCaptcha' => 1 value as 0 in config file. Anyway thanks for your immediate responses
    – Sabin
    Jul 30, 2021 at 5:47
  • May you please upvote my answer. Jul 30, 2021 at 6:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.