0

I'm trying to install the community edition by composer 2.1.2 but the logs show that I have the php8 installed and that I must use the php7. I have already installed the php7 but still requiring the right version. So please can anyone help.

composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition=2.4.0 /home/magento/

Your requirements could not be resolved to an installable set of packages.

**Problem 1

  • Root composer.json requires magento/product-community-edition 2.4.0 -> satisfiable by magento/product-community-edition[2.4.0].
  • magento/product-community-edition 2.4.0 requires php ~7.3.0||~7.4.0 -> your php version (8.0.7) does not satisfy that requirement.**

php -v

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.