0

I tried to upgrade Magento from 2.2.4 to 2.3.7 This is what i tried

composer require magento/composer-root-update-plugin=~1.0 --no-update
composer update --ignore-platform-reqs
cp composer.json composer.json.bak
composer remove magento/product-community-edition --no-update
composer require magento/product-community-edition 2.4.1 --no-update
composer update --ignore-platform-reqs

I got this errors

 Problem 1
- magento/project-community-edition 2.2.1 requires magento/product-community-edition 2.2.1 -> satisfiable by magento/product-community-edition[2.2.1] but these conflict with your requirements or minimum-stability.
- magento/project-community-edition 2.2.1 requires magento/product-community-edition 2.2.1 -> satisfiable by magento/product-community-edition[2.2.1] but these conflict with your requirements or minimum-stability.
- magento/product-community-edition 2.3.7 requires temando/module-shipping 2.0.0 -> satisfiable by temando/module-shipping[2.0.0].
- magento/product-community-edition 2.3.7 requires temando/module-shipping 2.0.0 -> satisfiable by temando/module-shipping[2.0.0].
- temando/module-shipping 2.0.0 requires temando/module-shipping-remover 1.0.0 -> satisfiable by temando/module-shipping-remover[1.0.0].
- temando/module-shipping 2.0.0 requires temando/module-shipping-remover 1.0.0 -> satisfiable by temando/module-shipping-remover[1.0.0].
- don't install temando/module-shipping-remover 1.0.0|remove magento/project-community-edition 2.2.1
- don't install temando/module-shipping-remover 1.0.0|remove magento/project-community-edition 2.2.1
- Installation request for magento/project-community-edition 2.2.1 -> satisfiable by magento/project-community-edition[2.2.1].
- Installation request for magento/product-community-edition 2.3.7 -> satisfiable by magento/product-community-edition[2.3.7].

So i tried to change version in composer.json in the global scope

"version": "2.3.7",

Composer update

Now i got those errors

Problem 1
- Conclusion: don't install magento/product-community-edition 2.3.7
- Conclusion: remove zendframework/zend-mail 2.6.2
- Conclusion: don't install zendframework/zend-mail 2.6.2
- Installation request for magento/product-community-edition 2.3.7 -> satisfiable by magento/product-community-edition[2.3.7].
- Conclusion: don't install zendframework/zend-mail 2.6.1
- magento/product-community-edition 2.3.7 requires laminas/laminas-mail ^2.9.0 -> satisfiable by laminas/laminas-mail[2.10.0, 2.10.1, 2.10.2, 2.11.0, 2.11.1, 2.12.0, 2.12.1, 2.12.2, 2.12.3, 2.12.4, 2.12.5, 2.13.0, 2.13.1, 2.14.0, 2.14.1, 2.9.0].
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.10.0
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.10.1
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.10.2
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.11.0
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.11.1
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.12.0
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.12.1
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.12.2
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.12.3
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.12.4
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.12.5
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.13.0
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.13.1
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.14.0
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.14.1
- don't install zendframework/zend-mail 2.6.0|don't install laminas/laminas-mail 2.9.0
- Installation request for zendframework/zend-mail ~2.6.0 -> satisfiable by zendframework/zend-mail[2.6.0, 2.6.1, 2.6.2].
0

You can try the following steps:

  1. Remove vendor/*
  2. Remove composer.lock
  3. Modify composer.json with your target Magento version

Run composer update

More Detail

5
  • Thanks, it installed dependancies but in the end i got error [InvalidArgumentException] Package is not installed: magento/project-community-edition-2.3.7.0 do you have if the update is succeeded or not? Jul 3 at 19:21
  • I think you need to modify composer.json, that is old. Compare 2.24 and 2.3.7, then modify. Specially: github.com/magento/magento2/blob/2.3/composer.json#L130
    – Sohel Rana
    Jul 4 at 3:20
  • Also, you can try using composer version 1, not 2.
    – Sohel Rana
    Jul 4 at 3:25
  • I have changed composer.json and mixe it by new and old version the composer seems working now i got this error Fatal error: Uncaught Error: Class 'Magento\Framework\Component\ComponentRegistrar' not found in /home/wetag/public_html/vendor/cart2quote/module-features/registration.php:7 What should i do? Jul 5 at 19:30
0

I did upgrade 2.3.4 to 2.3.7 just some day ago via below commands. hope it works for you.

*)set developer mode

  1. php bin/magento -d memory_limit=6G maintenance:enable

  2. composer require magento/product-community-edition 2.3.7 --no-update

  3. composer require --dev phpunit/phpunit:~6.2.0 friendsofphp/php-cs-fixer:~2.10.1 lusitanian/oauth:~0.8.10 pdepend/pdepend:2.5.2 sebastian/phpcpd:~3.0.0 squizlabs/php_codesniffer:3.2.2 --no-update 4) composer remove --dev sjparkinson/static-review fabpot/php-cs-fixer --no-update

  4. composer update or upload composer.phar in root and run php -d memory_limit=6G composer.phar update

  5. rm -rf var/cache/* generated/code/* var/view_preprocessed/* var/page_cache/* var/report/* pub/static/frontend/* pub/static/adminhtml/* pub/static/_cache/merged/*

  6. php bin/magento setup:upgrade

  7. php bin/magento setup:static-content:deploy -f

  8. php bin/magento setup:di:compile

  9. php bin/magento indexer:reindex

  10. php bin/magento cache:clean

  11. php bin/magento cache:flush

After upgrade, check your Magento version with the following command:

  1. php bin/magento --version

  2. php bin/magento maintenance:disable

  3. Php version set 7.4 via cpanel or htaccess

Hope this help you :)

1
  • can you share your initial composer.json file? Jul 6 at 12:45
0

Try to add --ignore-platform-reqs=>1 after your command.

1
  • i've already done composer update --ignore-platform-reqs Jul 6 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.