0

I want to update Magento from version 2.3.3 to 2.3.7. I have installed php 7.4 in my system.

I used below commands but facing errors.

sudo composer require magento/product-community-edition 2.3.7 --no-update 
sudo composer update -vvv


Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/magento2-functional-testing-framework 2.4.5 requires php 7.0.2||7.0.4||~7.0.6||~7.1.0||~7.2.0||~7.3.0 -> your PHP version (7.4.10) does not satisfy that requirement.
    - magento/magento2-functional-testing-framework 2.4.5 requires php 7.0.2||7.0.4||~7.0.6||~7.1.0||~7.2.0||~7.3.0 -> your PHP version (7.4.10) does not satisfy that requirement.
    - Installation request for magento/magento2-functional-testing-framework 2.4.5 -> satisfiable by magento/magento2-functional-testing-framework[2.4.5].

Can someone guide me which way I should follow?

6
  • Maybe you have set magento/magento2-functional-testing-framework in jour composer.json file to version 2.4.5. If so you can remove it from composer.json or change it to the latest version (don't know which version that is) Commented Jul 2, 2021 at 7:00
  • If I set to 2.4,5 then it gets unsupported by 7.4
    – Arjun
    Commented Jul 2, 2021 at 7:02
  • If you are not really using the functional testing framework you can execute composer remove magento/magento2-functional-testing-framework Commented Jul 2, 2021 at 7:09
  • you need to downgrade php version as it is not supported by 2.3.3 neither 2.3.7 . i think you should go with 7.3
    – Pramod
    Commented Jul 2, 2021 at 8:20
  • @Pramod I checked the docs it says 2.3.7 supports 7.4 devdocs.magento.com/guides/v2.4/install-gde/…
    – Arjun
    Commented Jul 2, 2021 at 8:38

2 Answers 2

1

Update comoser.json with

"magento/magento2-functional-testing-framework": "3.1.0"
0
  1. Backup the composer.json file.

cp composer.json composer.json.bak

  1. Add or remove specific packages based on your needs. For example, if you are upgrading from Magento Open Source to Adobe Commerce, remove the Magento Open Source package.

composer remove magento/product-community-edition --no-update

  1. Choose one of the following composer commands based on the PHP version, and run the command to upgrade your instance.

For 7.3 or higher:

composer require magento/<product> <version> --no-update [--interactive-root-conflicts] [--force-root-updates] [--help]

For PHP 7.2 or lower:

composer require magento/<product> <version> --no-update [--interactive-magento-conflicts] [--use-default-magento-values] [--help]

Examples:

Magento Open Source:

composer require magento/product-community-edition 2.3.7 --no-update

  1. Update the dependencies.

composer update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.