0

I'm trying to upgrade Magento from 2.2.4 to 2.3.7

I got a lot of errors, so i fixed them by changing module's version, now

composer require magento/product-community-edition=2.3.7  --no-update
composer update

I got those errors

Problem 1
- magento/project-community-edition 2.2.1 requires magento/product-community-edition 2.2.1 -> satisfiable by magento/product-community-edition[2.2.1] but these conflict with your requirements or minimum-stability.
- magento/product-community-edition 2.3.7 requires temando/module-shipping 2.0.0 -> satisfiable by temando/module-shipping[2.0.0].
- magento/product-community-edition 2.3.7 requires temando/module-shipping 2.0.0 -> satisfiable by temando/module-shipping[2.0.0].
- temando/module-shipping 2.0.0 requires temando/module-shipping-remover 1.0.0 -> satisfiable by temando/module-shipping-remover[1.0.0].
- temando/module-shipping 2.0.0 requires temando/module-shipping-remover 1.0.0 -> satisfiable by temando/module-shipping-remover[1.0.0].
- don't install temando/module-shipping-remover 1.0.0|remove magento/project-community-edition 2.2.1
- remove magento/project-community-edition 2.2.1|remove temando/module-shipping-remover 1.0.0
- Installation request for magento/project-community-edition 2.2.1 -> satisfiable by magento/project-community-edition[2.2.1].
- Installation request for magento/product-community-edition 2.3.7 -> satisfiable by magento/product-community-edition[2.3.7].  

I changed the version in composer.json to 2.3.7 (for magento/project-community-edition) and i got installation started but then stopped with error

 [InvalidArgumentException]                                           
 Package is not installed: magento/project-community-edition-2.3.7.0 

Edit, i updrated Composer to version 2 i got those errors

 Problem 1
- Root composer.json requires fooman/printorderpdf-m2 ^3.3, it is  satisfiable by fooman/printorderpdf-m2[3.3.0, 3.3.1, 3.3.2] from  composer repo (https://repo.packagist.org) but fooman/printorderpdf- m2[3.1.0] from artifact repo (/home/wetag/public_html/vendor/fooman /packages) has higher repository priority. The packages with higher priority do not match your constraint and are therefore not installable. See https://getcomposer.org/repoprio for details and assistance.
Problem 2
- magento/project-community-edition is present at version 2.2.1  and cannot be modified by Composer
- temando/module-shipping 2.0.0 requires temando/module-shipping-remover 1.0.0 -> satisfiable by temando/module-shipping-remover[1.0.0].
- magento/product-community-edition 2.3.7 requires temando/module-shipping 2.0.0 -> satisfiable by temando/module-shipping[2.0.0].
- temando/module-shipping-remover[1.0.0] cannot be installed as that would require removing magento/project-community-edition[2.2.1]. They both replace temando/module-shipping-m2 and thus cannot coexist.
- Root composer.json requires magento/product-community-edition 2.3.7 -> satisfiable by magento/product-community-edition[2.3.7].
3
  • your composer version?
    – kanidhaya
    Jun 29, 2021 at 15:47
  • @kanidhaya 1.10.22 Jun 29, 2021 at 15:48
  • In 2.3.7 needs composer version 2 please update your composer version then try it will fix
    – kanidhaya
    Jun 29, 2021 at 15:50

1 Answer 1

0

for magento 2.3.7 Needs composer version 2 please upgrade your composer version 2 composer self-update --2 then try it it will fixed

3
  • i updated my question with the errors after upgrading composer Jun 29, 2021 at 15:57
  • after upgrade did u run composer update in your magento root folder?
    – kanidhaya
    Jun 29, 2021 at 15:58
  • yes i did, i upgrated composer to version 2 and after i runned composer update Jun 29, 2021 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.