0

As per the requirement I need to integrate Google Pay in my Magento 2 site. But I am getting an error added below.

Command

php -dmemory_limit=6G vendor/bin/composer require unboundcommerce/module-googlepay 1.1.1

also tried with

php -dmemory_limit=6G vendor/bin/composer require unboundcommerce/module-googlepay:v1.1.1

But getting same error message

Could not find a matching version of package unboundcommerce/module-googlepay. Check the package spelling, your version constrai nt and that the package is available in a stability which matches your minimum-stability (stable).

enter image description here

Magento Version : 2.3.5-p1

Composer : 1.10.22

Module URL : unboundcommerce/module-googlepay

Thanks in advance

0

You need to use following command:

composer require unboundcommerce/module-googlepay:1.1.1

or

php -dmemory_limit=6G vendor/bin/composer require unboundcommerce/module-googlepay:1.1.1
1
  • Thak you for your reply, I tried the command in both Composer 1 and 2, but getting same error. I have added a screenshot in the question.
    – Dipu R
    Jun 29 at 8:33
0

composer require unboundcommerce/module-googlepay:1.1.1 Do not run Composer as root/super user! See https://getcomposer.org/root for details Continue as root/super user [yes]? ./composer.json has been updated Running composer update unboundcommerce/module-googlepay Loading composer repositories with package information In Laminas\DependencyPlugin\DependencyRewriterV2::onPrePoolCreate Updating dependencies Your requirements could not be resolved to an installable set of packages.

Problem 1 - Root composer.json requires unboundcommerce/module-googlepay 1.1.1 -> satisfiable by unboundcommerce/module-googlepay[1.1.1]. - unboundcommerce/module-googlepay 1.1.1 requires firebase/php-jwt 5.0.0 -> found firebase/php-jwt[v5.0.0] but the package is fixed to v5.4.0 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

0

try

unboundcommerce-public/module-googlepay

isnstead of

unboundcommerce/module-googlepay
0

please cross-check the package name.

https://packagist.org/packages/unboundcommerce-public/module-googlepay

you are executing the composer command with the wrong package name

please use: composer require unboundcommerce-public/module-googlepay

instead of composer require unboundcommerce/module-googlepay:1.1.1

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.