0

The extension was not installed with composer

I deleted the files from app/code

I disabled the module bin/magento module:disable module_name

I uninstalled it bin/magento module:uninstall -r -c module_name

I am in developer mode, but I still ran
php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy

and flushed the cache

I also removed / drop table in the database and made sure it doesn't show up in setup_module in the database.

but when I run
php bin/magento module:status
it still shows up in the disabled module list. How do I get rid of it?

Update: I deleted the module out of the app/etc/config.php

I ran php bin/magento setup:updrade

and now its as if I didn't uninstall anything. It's back in the database everywhere, it is enabled and the config.php file has the entry back in it.

Where is the instruction to do this coming from?

Update: As recommended I removed it from the magento core folder or vendor folder.

That caused an error so I had to run this command to fix it:
composer dumpautoload

1 Answer 1

-1

open your magentoRootDirecotry/app/etc/config.php file and find your module there, just remove it and it's gone! I don't think it would harm anything but if it does please mention in comments.

3
  • Thanks for that it is gone. I have a new problem now though. if I run setup:upgrade it re-installs the module into the database! Commented Jun 25, 2021 at 2:26
  • It looks like the module is now in the enabled list, I have no idea how that happened! Is it because I ran setup:upgrade? Commented Jun 25, 2021 at 2:46
  • remove the module from the core folder of your Magento. Every time you run setup:upgrade command, it will reinstall all the modules from core folder unless they are disabled or removed from that folder. Commented Jun 25, 2021 at 6:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.