1

I am trying to upgrade my Magento 2.3.3 to Magento 2.4.1 running the below commands.

1.composer require magento/composer-root-update-plugin=~1.0 --no-update

2.composer update

3.composer require magento/product-community-edition=2.4.1 --no-update

4.composer update

after this step i get this error

enter image description here

I have tried this thing but not getting anything

composer require symfony/config:4.1.*

composer require symfony/dependency-injection:3.3.*

composer update

composer require --dev phpunit/phpunit:~6.2.0 friendsofphp/php-cs-fixer:~2.10.1 lusitanian/oauth:~0.8.10 pdepend/pdepend:2.5.2 sebastian/phpcpd:~3.0.0 squizlabs/php_codesniffer:3.2.2 --no-update

1 Answer 1

1

The magento/data-migration-tool version needs updating to match the magento version that you're updating to. That should remedy the version conflict.

1
  • solved my problem thank you!
    – SR_Magento
    Sep 28, 2021 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.