0

I need to disable Page Cache so it does not keep old data on the page.

When I dIsable it from admin panel it works, but then it gets backs to enabled by no reason.

Is there a way I can keep it disabled like the image below:

enter image description here

1

The admin setting you are adding should stay disabled if you set it like that in a vanilla Magento installation. I am assuming you have some customizations in place, maybe some environment specifics (setups, builds, etc), so I would check those first to isolate which process re-enables FPC.

Whether you disable if from the GUI or programmatically, if there's something somewhere which says FPC should be enabled, it would definitely overwrite your programmatic FPC disabling.

4
  • do you think it could be because of some extra modules? the only module that I have installed besides mine is Stripe, and my module does not do anything with the cache. Or if I run this commands php bin/magento cache:clean and cache:flush could be the problem? – Oscar Vazquez Jun 17 at 14:28
  • running cache clearing or flushing commands won't re-enable the FPC. i am still thinking of a customization somewhere or an additional process in a pipeline or a setup. – Diana Botean Jun 17 at 14:38
  • 1
    thanks for the tip! I think I can do that research now – Oscar Vazquez Jun 17 at 14:39
  • no problem, anytime! – Diana Botean Jun 17 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.