0

I am trying to install Magento 2.4.2 on my windows machine using wamp. Getting 404 error after installed the Magento successfully.

Can anyone please help?

1
  • Steps I followed to resolve the issue: ----------------------------------------------------------------------------- php bin/magento config:set web/seo/use_rewrites 0 ------------------------------------------------------------ bin/magento deploy:mode:set developer ------------------------------------------------------------------------ php bin/magento cache:clean----------------------------------------------------------------------------------- Added virtual host using Wamp
    – Octopus
    Jun 16, 2021 at 10:51

3 Answers 3

1

Option.1

go to below configuration in admin

Stores -> Configurations -> General ->Web -> Search Engine Optimization -> Use Web Server Rewrites

and disable "Use Web Server Rewrites".


Option.2

run below command from ssh

php bin/magento config:set web/seo/use_rewrites 0 
php bin/magento cache:clean

if it works for you that mean issue with php rewrite module

hope this helps you :)

2
  • Hi, I have followed the second option. In addition to that, I have set the default mode as a developer. bin/magento deploy:mode:set developer
    – Octopus
    Jun 16, 2021 at 10:48
  • second option works for you?? and yes its better to work in developer mode instead of default mode Jun 16, 2021 at 11:19
0

Kindly verify the .htaccess in base folder pub/static folder.

0

Check that your webserver document root folder is set to the magento/pub folder

e.g. for Apache

DocumentRoot /var/www/magento2/pub/
1
  • Since am using windows, I have added this step using wamp's VirtualHost management
    – Octopus
    Jun 16, 2021 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.