5

Since Magento is planning on using Zend Framework 2, does that mean that all the current extensions that utilize ZF1 are going to break? From what I know about ZF2 and ZF1 is that they are very different in some ways. Especially with namespaces. Wouldn't this hurt them a little? Or, do you think they are anticipating that ZF2 will be a hit?

  • There is no official condirmation from Magento that it will be using Zf2..the current git repo of Magento 2 is on ZF 1 – huzefam Aug 29 '14 at 2:31
8

AFAIK Magento 2 will not use ZF2.
But this is not relevant to your problem.
Since there is no backwords compatibility between Magento 2 and Magento 1 all the extensions that exist for Magento 1 will not work for Magento 2 anyway no matter what ZF version is used.

  • That's crazy that they aren't going to have backwards compatibility. I wonder what people are going to do about their magento websites. – Aedonis Aug 29 '14 at 15:30
  • @RoshniTaylor. keep them on 1.x. There will still be support for a while for 1.x. But I'm sure there will be migration tools from 1.x to 2.0. Either provided by magento or 3rd parties. And breaking backwards compatibility is not that crazy. It's a major version change. – Marius Aug 29 '14 at 15:41
  • Or e-commerce site operators frustrated with 1.x will jump on magento2 as soon as they have it sufficiently configured on dev servers. (this would be me) – Chris K Sep 9 '14 at 20:45
4

It is not planned that Magento 2 uses Zend Framework 2 as this GitHub issue proves. There is also no other information regarding this topic in the Magento 2 Wiki.

2

We view Magento as it's own framework and usage of other code more as libraries to be leveraged. If you look at Magento 2 Dev Beta you'll see ZF1, ZF2, and Symphony libraries being used. Internally we view these libraries in groups that support specific functionality or business objectives and will address their possible upgrade/etc as appropriate in that view.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.