1

I just recently upgraded our Magento store to version 2.4.2 and 2 factor authentication is enabled by default in the admin. That is fine and it is working, however whenever I sign in to the admin and go to enter my Google authenticator code, there is no option to "Trust this device" or "Remember me" or anything like that. This is what my site shows:

what my site is displaying

This means that every time I log out or close the browser window it forced me to log back in and provide another code. This is very frustrating when coming back and forth to the site. In looking up the official documentation for this, it states and even shows a screenshot with a checkbox under the authenticator code field saying "Trust this device, do not ask again":

what it should look like

I cannot find any information or documentation on why this is not appearing for me. I have tried looking through the codebase and it does not look like it is coming from there. In the admin setup for Google Authenticator (under Security > 2 FA) the only option is the OTP window. I don't see anywhere to enable or add this but it is not showing and working up.

Can anyone please help?

1 Answer 1

2

For anyone else that might stumble upon this, I contacted Magento support and they informed me that in 2.4.2 and above this feature has been deliberately removed (even though it doesn't say this in the documentation and their own screencap pictured above still shows that checkbox). It does not exist intentionally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.