0

Am trying to install any module using composer v.1 and v.2 but I get this error all the time

 Problem 1
    - The requested package laminas/laminas-servicemanager (locked at 2.7.11, required as ^3.6) is satisfiable by laminas/laminas-servicemanager[2.7.11] but these conflict with your requirements or minimum-stability.
  Problem 2
    - magento/magento2-base 2.4.1 requires laminas/laminas-servicemanager ^2.7.8 -> satisfiable by laminas/laminas-servicemanager[2.7.10, 2.7.11, 2.7.8, 2.7.9] but these conflict with your requirements or minimum-stability.
    - magento/magento2-base 2.4.1 requires laminas/laminas-servicemanager ^2.7.8 -> satisfiable by laminas/laminas-servicemanager[2.7.10, 2.7.11, 2.7.8, 2.7.9] but these conflict with your requirements or minimum-stability.
    - magento/magento2-base 2.4.1 requires laminas/laminas-servicemanager ^2.7.8 -> satisfiable by laminas/laminas-servicemanager[2.7.10, 2.7.11, 2.7.8, 2.7.9] but these conflict with your requirements or minimum-stability.
    - magento/magento2-base 2.4.1 requires laminas/laminas-servicemanager ^2.7.8 -> satisfiable by laminas/laminas-servicemanager[2.7.10, 2.7.11, 2.7.8, 2.7.9] but these conflict with your requirements or minimum-stability.
    - Installation request for magento/magento2-base (locked at 2.4.1) -> satisfiable by magento/magento2-base[2.4.1].


Installation failed, reverting ./composer.json to its original content.

Here below is the require section on the composer.json file

   {
   ...
   "require": {
        "dompdf/dompdf": "^1.0",
        "laminas/laminas-barcode": "^2.9",
        "laminas/laminas-servicemanager": "^3.6",
        "magento/composer-root-update-plugin": "~1.0",
        "magento/product-community-edition": "2.4.1",
        "mailchimp/mc-magento2": "102.3.42",
        "tijsverkoyen/css-to-inline-styles": "^2.2",
        "vnecoms/module-core": "2.4.0",
        "vnecoms/module-sms": "2.4.1",
        "vnecoms/module-sms-unifonic-nextgen": "2.0.1",
        "vnecoms/unifonic-nextgen-sdk": "1.0.0"
    },
...
}
2
  • Can you share you composer.json? At least the require section? – viniciusbord9 Jun 16 at 3:28
  • 1
    am not sure what I did is right but I delete "require-dev" and "require" list then I try to install a module is work fine – emad masauod Jun 16 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.