1

I am trying to upgrade from 2.3.5p1 to 2.3.7 using Composer version 1.9.1, on a computer with PHP 7.3.

First i run: php composer.phar require magento/product-community-edition 2.3.7 --no-update

I get:

Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Magento Open Source 2.3.7 is trying to add require:magento/composer-root-update-plugin=~1.1 but it is instead ~1.0 in this installation and will not be changed.  Re-run using --use-default-magento-values or --interactive-magento-conflicts to override with Magento values.
Magento Open Source 2.3.7 is trying to change the existing order of the require section.
Local order:
   [
      magento/composer-root-update-plugin,
      magento/product-community-edition
   ]
Magento Open Source 2.3.7 order:
   [
      magento/product-community-edition,
      magento/composer-root-update-plugin
   ] but it will not be changed. Re-run using --use-default-magento-values or --interactive-magento-conflicts to override with the Magento order.
Updating composer.json for Magento Open Source 2.3.7 ...
./composer.json has been updated

And then i run: export COMPOSER_MEMORY_LIMIT=99999999999 && php -d memory_limit=-1 composer.phar update

I am getting the following errors:

Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/framework 101.0.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.1 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.2 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.3 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.4 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.5 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.6 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.7 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 102.0.0 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 102.0.1 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.8 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 102.0.2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.9 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.10 requires php ~7.0.13|~7.1.0|~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 102.0.2-p2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.11 requires php ~7.0.13||~7.1.0||~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.1 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.2 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.3 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.4 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.5 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.6 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.7 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 102.0.0 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 102.0.1 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.8 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 102.0.2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.9 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.10 requires php ~7.0.13|~7.1.0|~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 102.0.2-p2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - magento/framework 101.0.11 requires php ~7.0.13||~7.1.0||~7.2.0 -> your PHP version (7.3.26) does not satisfy that requirement.
    - Conclusion: don't install magento/product-community-edition 2.3.7
    - magento/framework 102.0.6-p1 requires laminas/laminas-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1].
    - magento/framework 102.0.6 requires laminas/laminas-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1].
    - magento/framework 102.0.5-p2 requires laminas/laminas-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1].
    - magento/framework 102.0.4-p2 requires zendframework/zend-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1], zendframework/zend-code[3.3.0, 3.3.1, 3.3.2].
    - magento/framework 102.0.5 requires laminas/laminas-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1].
    - magento/framework 102.0.3-p1 requires zendframework/zend-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1], zendframework/zend-code[3.3.0, 3.3.1, 3.3.2].
    - magento/framework 102.0.4 requires zendframework/zend-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1], zendframework/zend-code[3.3.0, 3.3.1, 3.3.2].
    - magento/framework 102.0.3 requires zendframework/zend-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1], zendframework/zend-code[3.3.0, 3.3.1, 3.3.2].
    - magento/framework 102.0.6-p1 requires laminas/laminas-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1].
    - magento/framework 102.0.6 requires laminas/laminas-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1].
    - magento/framework 102.0.5-p2 requires laminas/laminas-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1].
    - magento/framework 102.0.4-p2 requires zendframework/zend-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1], zendframework/zend-code[3.3.0, 3.3.1, 3.3.2].
    - magento/framework 102.0.5 requires laminas/laminas-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1].
    - magento/framework 102.0.3-p1 requires zendframework/zend-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1], zendframework/zend-code[3.3.0, 3.3.1, 3.3.2].
    - magento/framework 102.0.4 requires zendframework/zend-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1], zendframework/zend-code[3.3.0, 3.3.1, 3.3.2].
    - magento/framework 102.0.3 requires zendframework/zend-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1], zendframework/zend-code[3.3.0, 3.3.1, 3.3.2].
    - magento/framework 102.0.5 requires laminas/laminas-code ~3.3.0 -> satisfiable by laminas/laminas-code[3.3.2, 3.3.0, 3.3.1].
    - Can only install one of: laminas/laminas-code[3.4.1, 3.3.0].
    - Can only install one of: laminas/laminas-code[3.4.1, 3.3.1].
    - Can only install one of: laminas/laminas-code[3.4.1, 3.3.2].
    - Can only install one of: laminas/laminas-code[3.4.1, 3.3.2].
    - don't install zendframework/zend-code 3.3.0|don't install laminas/laminas-code 3.4.1
    - don't install zendframework/zend-code 3.3.1|don't install laminas/laminas-code 3.4.1
    - don't install zendframework/zend-code 3.3.2|don't install laminas/laminas-code 3.4.1
    - magento/product-community-edition 2.3.7 requires laminas/laminas-code ~3.4.1 -> satisfiable by laminas/laminas-code[3.4.1].
    - Installation request for magento/product-community-edition 2.3.7 -> satisfiable by magento/product-community-edition[2.3.7].
    - fooman/pdfcustomiser-m2 8.5.4 requires magento/framework 101.0.0 - 101.0.11 | >=102.0.0 < 102.0.7 | >=103.0.0 < 103.0.2 -> satisfiable by magento/framework[102.0.5, 103.0.1-p1, 102.0.6-p1, 103.0.1, 102.0.6, 103.0.0-p1, 103.0.0, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 101.0.11, 102.0.2-p2, 101.0.10, 102.0.3, 101.0.9, 102.0.2, 101.0.8, 102.0.1, 102.0.0, 101.0.7, 101.0.6, 101.0.5, 101.0.4, 101.0.3, 101.0.2, 101.0.1, 101.0.0].
    - fooman/pdfcustomiser-m2 8.5.4 requires magento/framework 101.0.0 - 101.0.11 | >=102.0.0 < 102.0.7 | >=103.0.0 < 103.0.2 -> satisfiable by magento/framework[102.0.5, 103.0.1-p1, 102.0.6-p1, 103.0.1, 102.0.6, 103.0.0-p1, 103.0.0, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 101.0.11, 102.0.2-p2, 101.0.10, 102.0.3, 101.0.9, 102.0.2, 101.0.8, 102.0.1, 102.0.0, 101.0.7, 101.0.6, 101.0.5, 101.0.4, 101.0.3, 101.0.2, 101.0.1, 101.0.0].
    - fooman/pdfcustomiser-m2 8.5.4 requires magento/framework 101.0.0 - 101.0.11 | >=102.0.0 < 102.0.7 | >=103.0.0 < 103.0.2 -> satisfiable by magento/framework[102.0.5, 103.0.1-p1, 102.0.6-p1, 103.0.1, 102.0.6, 103.0.0-p1, 103.0.0, 102.0.5-p2, 102.0.4-p2, 102.0.3-p1, 102.0.4, 101.0.11, 102.0.2-p2, 101.0.10, 102.0.3, 101.0.9, 102.0.2, 101.0.8, 102.0.1, 102.0.0, 101.0.7, 101.0.6, 101.0.5, 101.0.4, 101.0.3, 101.0.2, 101.0.1, 101.0.0].
    - Can only install one of: magento/framework[102.0.7, 103.0.1-p1].
    - Can only install one of: magento/framework[102.0.7, 103.0.1].
    - Can only install one of: magento/framework[102.0.7, 103.0.0-p1].
    - Can only install one of: magento/framework[102.0.7, 103.0.0].
    - Can only install one of: magento/framework[103.0.1-p1, 102.0.7].
    - Can only install one of: magento/framework[103.0.1, 102.0.7].
    - Can only install one of: magento/framework[103.0.0-p1, 102.0.7].
    - Can only install one of: magento/framework[103.0.0, 102.0.7].
    - magento/product-community-edition 2.3.7 requires magento/framework 102.0.7 -> satisfiable by magento/framework[102.0.7].
    - Conclusion: don't install magento/framework 102.0.7
    - Installation request for fooman/pdfcustomiser-m2 8.5.4 -> satisfiable by fooman/pdfcustomiser-m2[8.5.4].

What should I do to overcome these errors?

The solution to upgrade was to remove 3 lines for the Fooman extensions from the composer.json and run update with --ignore-platform-reqs as suggested by jiheison.

3
  • 1
    You can use --ignore-platform-reqs to get around the PHP version check. fooman/pdfcustomiser-m2 is another story. I have had the same problem, and the best solution I have found is to remove that extension completely, upgrade Magento, and then install the latest extension version. The reason is that it is (annoyingly) full of very specific magento module requirements.
    – jiheison
    Commented Jun 5, 2021 at 18:02
  • You can do the upgrade and once that is completed then you can change PHP to 7.3 Commented Jun 5, 2021 at 18:48
  • The solution from jiheison worked for me. Thank you. Commented Jun 6, 2021 at 6:15

3 Answers 3

0

As for the first portion of your question, it simply asking you to rerun the command using --interactive-magento-conflicts so it can make the necessary adjustments to the composer.json file.

Please refer to https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html

0

I used Php7.4 than Php7.3. I successfully upgraded 2.3.3 to 2.3.7 without any error.

0
  1. Backup the composer.json file.

cp composer.json composer.json.bak

  1. Add or remove specific packages based on your needs. For example, if you are upgrading from Magento Open Source to Adobe Commerce, remove the Magento Open Source package.

composer remove magento/product-community-edition --no-update

  1. Choose one of the following composer commands based on the PHP version, and run the command to upgrade your instance.

For 7.3 or higher:

composer require magento/<product> <version> --no-update [--interactive-root-conflicts] [--force-root-updates] [--help]

For PHP 7.2 or lower:

composer require magento/<product> <version> --no-update [--interactive-magento-conflicts] [--use-default-magento-values] [--help]

Examples:

Magento Open Source:

composer require magento/product-community-edition 2.3.7 --no-update

  1. Update the dependencies.

composer update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.