1

When I placed the order using stripe payment method. I am able to received the order confirmation email but invoice email not received. Invoice email manually hit works.

Magento 2.3.2

2
  • Is your site configured to send invoice emails? It's under Stores -> Configuration -> Sales -> Sales Emails.
    – David Tay
    May 31, 2021 at 13:50
  • Check any third party extension use related to invoice functionlity? then try to disable that one. also check your magento log as well, is that anything there. Jun 1, 2021 at 4:53

1 Answer 1

2

There could be several reasons why the invoice email is not being sent automatically when an order is placed using the Stripe payment method in Magento 2.3.2. Here are some troubleshooting steps you can try:

  • Check the email settings in Magento: Make sure that the email notifications are enabled for the invoice email template. Go to Stores > Configuration > Sales > Sales Emails, and make sure that "Enabled" is set to "Yes" for the "Invoice" email template.

  • Check the Stripe payment method configuration: Make sure that the "Send Invoice Email" option is set to "Yes" in the Stripe payment method configuration. Go to Stores > Configuration > Sales > Payment Methods > Stripe, and make sure that "Send Invoice Email" is set to "Yes".

  • Check the cron jobs: The automatic sending of invoice emails is triggered by the Magento cron jobs. Make sure that the cron jobs are set up correctly and running as expected. You can check this by running the following command from your Magento root directory: php bin/magento cron:check

  • Check the email logs: Check the Magento email logs to see if there are any errors or issues related to the invoice emails. You can find the email logs in the Magento database, in the email_log table.

  • Check with your email provider: If none of the above steps resolve the issue, check with your email provider to see if there are any issues on their end that might be preventing the invoice emails from being sent.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.