0

When I try to run upgrade and reindex Command on terminal it's showing an error No alive node found in you cluster, I am not able to set up elasticsearch Configuration on backend showing an same error. sudo command also not working it's showing an command not found. I have attached snap of the error for you reference.

Error showing on terminal while running upgrade cmd

Backend Configuration Error testing

3 Answers 3

0

It means your elasticsearch is not running. make sure elasticsearch service is started before running command.

4
  • Thanks for you reply. I facing an error as command not found on terminal, i have run the cmd on root file. May 25, 2021 at 10:48
  • have u installed elasticsearch? May 25, 2021 at 10:58
  • yes i have installed elasticsearch May 25, 2021 at 11:45
  • then your server should always enabled. this error will occur if elasticsearch is not enable on your computer/server May 25, 2021 at 14:09
0

Check Status of Elasticsearch

service elasticsearch status

if elasticsearch is status is inactive try starting using

service elasticsearch status

if you are facing issue while starting elasticsearch

vi /var/log/elasticsearch/elasticsearch.log
3
  • Thanks for you reply, I have run the command but it's showing as error on terminal bash: service: command not found May 25, 2021 at 10:46
  • are you using on windows?
    – Waqar Ali
    May 25, 2021 at 10:47
  • I have running the command on cpanel using Linux terminal. May 25, 2021 at 10:57
0

After you open your terminal then
Please Try these command to start and enable elastic search.

systemctl start elasticsearch
systemctl enable elasticsearch
systemctl status elasticsearch

bin/magento setup:upgrade
bin/magento setup:di:compile
bin/magento setup:static-content:deploy -f
chmod -R 777 var pub
bin/magento c:c
bin/magento c:f

Then refresh your browser.
Let me know if you got any issues.

2
  • Thanks for you reply, when i try to run the command it's showing as systemct1 command not found error and also i run adding php before the cmd it's showing Could not open input file systemctl, can you help me to rectify the issue. May 25, 2021 at 10:50
  • its not systemct1 but its systemctl where l for lion.. Please share the screenshot of error also. May 25, 2021 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.