0

My general customer view frontend is working fine.
But when I tried to login into the admin area , then
I enter this in address of chrome web browser -
http://127.0.0.1/local_m241/lcl_m241/index.php/admin_17r9pn
Then got auto-redirected to this -
http://127.0.0.1/local_m241/lcl_m241/admin_17r9pn/admin/index/index/key/6a5ef2a519b65baf9f4c74860c9e7a6a45ae537c24a35f1e77683f5cf0f4f5d1/
and this page shows 404 error as shown in below picture.
enter image description here

5

1 Answer 1

0

Reference tutorial that helped me in solving this problem is
https://magecomp.com/blog/fix-404-error-page-not-found-admin-url-magento-2/
Here Solution number 2 worked for me - Enable Rewrite mode of apache2.
Steps are -

sudo a2enmod rewrite

For Ubuntu / Debian edit the file /etc/apache2/apache2.conf. To edit this file run command

sudo vi /etc/apache2/apache2.conf

Modify from

<Directory /var/www/>
         Options Indexes FollowSymLinks
         AllowOverride None
         Require all granted
</Directory>

to

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

Then restart apache

sudo service apache2 restart

or

sudo /etc/init.d/apache2 restart

or

sudo systemctl restart apache2

And it worked fine for me :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.