I have successfully cloned & installed a Magento cloud environment Magento 2.4.2 in my local instance.

And also installed elastic search and tested it via the command line and it's working fine.

Note: I have followed his link to install and configure elastic search https://www.emizentech.com/blog/magento-2-4-with-elasticsearch-complete-guide.html

Output from the command line: enter image description here

But while running upgrade command throws following error.

enter image description here

Elastic search configuration file


enter image description here

Can anyone please help me to sort out this?


1 Answer 1


Just restart the service :)

sudo systemctl stop elasticsearch
sudo systemctl start elasticsearch

You may also need to execute:

sudo systemctl enable elasticsearch

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.