In /var/log/exception.log, I've been getting the following ERROR for over a week and can't figure out how to fix it:

main.ERROR: Can not resolve reCAPTCHA parameter. {"exception":"[object] (Magento\\Framework\\Exception\\InputException(code: 0): Can not resolve reCAPTCHA parameter. at /var/www/html/magento/vendor/magento/module-re-captcha-ui/Model/CaptchaResponseResolver.php:25)"} []

reCAPTCHA seems to be working, despite the error msg.

[edited to add]: I'm using reCAPTCHA v3 Invisible on Storefront, so I suppose I wouldn't know if it was allowing everyone through - not sure how to test that it is rejecting when it should.

I've tried re-setting the file and directory permissions, clearing and flushing cache, re-indexing. None of these things have resolved it.

BTW, I switched my store from production mode to developer mode, but receiving the reCAPTCHA ERROR in the exception.log regardless of mode.

Please tell me how to fix this? Thanks, Evelyn

  • Did you ever find a solution to this?
    – Webninja
    Sep 20, 2021 at 11:43
  • @Webninja no, I haven't. I have since upgraded to Magento 2.4.2-p1, but still have this issue.
    – bluedarter
    Sep 22, 2021 at 4:53

5 Answers 5


I'm also currently facing the same issue on magento 2.4 with the type type_invisible. My keys are 100% correct. Found this and it looks like it might be related to magento itself and the fact that it might just be a validation message issue due to magento himself not handling keys properly ? Don't really know what to think about it.

See : Magento community

If someone got more intell about the real cause behind all that, might be awesome. On my case i'm using


I think the problem is coming from your google API keys. Make sure these keys are correct

  • 1
    My google API keys are correct, they haven't changed and as I said reCAPTCHA seems to be working.
    – bluedarter
    May 14, 2021 at 15:48
  • 1
    Just to follow up: I re-entered my google API keys, because why not. About 3 hrs later, the same error appeared again in exception.log and debug.log. So it's not an issue with the keys.
    – bluedarter
    May 14, 2021 at 19:36

Same Problem on the Magento 2.4.2. both API keys are correct and ReCaptcha works on the contact page, login page, create account page but only Braintree credit form Recaptcha not working. It displays ReCaptcha but not doing validation.

Hope anyone has a solution please share

  • How did you find out what page the error originate from? We have the same error messages in 2.4.2 but doesn't know what page they are triggered on.
    – Aknot
    May 18, 2021 at 12:21
  • We don't see any error in the frontend and no error in the log file. ReCaptcha passes without validation.
    – K. Coffee
    May 20, 2021 at 5:33

I found out that the internet speed is very slow. The customer submitted the form before the Recaptcha component was generated. That causes the Recaptcha to not be validated in FE, but will cause an error in BE.


Mainly SPAM bots. Check the timestamp in the access log against the timestamp in the exception log. Check the IP address and you can usually see that it's just a SPAM bot trying to register accounts or submit to newsletter forms.

  • Have got any fix for spam register account? Dec 23, 2022 at 5:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.